GitProxy Backfile Parsing Exploit
CVE-2025-54584GHSA-xxmh-rf63-qwjv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@finos/git-proxy 1.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @finos/git-proxy
- Affected
- <= 1.19.1
- Fixed in
- 1.19.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xxmh-rf63-qwjv lists affected ranges: npm @finos/git-proxy >=0 <1.19.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xxmh-rf63-qwjv lists affected ranges: npm @finos/git-proxy >=0 <=1.19.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2025-54584: 0.57% estimated exploitation activity in the next 30 days; percentile 47.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker can craft a malicious Git packfile to exploit the PACK signature detection in the parsePush.ts. By embedding a misleading PACK signature within commit content and carefully constructing the packet structure, the attacker can trick the parser into treating invalid or unintended data as the packfile. Potentially, this would allow bypassing approval or hiding commits. Details The affected version of parsePush.ts attempts to locate the Git PACK file by looking for the last occurrence of the string "PACK" in the incoming push payload: This assumes that any "PACK" string near the end of the push is the beginning of the actual binary Git packfile. However, Git objects (commits, blobs, etc.) can contain arbitrary content (including the word PACK) in binary or non-compressed blobs. An attacker could abuse this by: 1. Crafting a custom packfile using low-level Git tools or by manually forging one 2. Placing the string "PACK" inside a commit body or a binary file blob that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xxmh-rf63-qwjv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xxmh-rf63-qwjv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54584 Advisory: GitProxy Backfile Parsing Exploit IDs: CVE-2025-54584, GHSA-xxmh-rf63-qwjv Record: https://patchnext.com/advisories/cve-2025-54584 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @finos/git-proxy 1.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @finos/git-proxy: affected <= 1.19.1; fixed in 1.19.2 ## Suggested inspection (read-only) - `npm ls @finos/git-proxy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @finos/git-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xxmh-rf63-qwjv (OSV record GHSA-xxmh-rf63-qwjv lists affected ranges: npm @finos/git-proxy >=0 <1.19.2 (fixed)) - Verified: https://github.com/advisories/GHSA-xxmh-rf63-qwjv (GitHub-reviewed advisory GHSA-xxmh-rf63-qwjv lists affected ranges: npm @finos/git-proxy >=0 <=1.19.1) Commands are suggestions: review each one before running it.
Loading voting…