GitProxy Approval Bypass When Pushing Multiple Branches
CVE-2025-54583GHSA-qr93-8wwf-22g4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@finos/git-proxy 1.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @finos/git-proxy
- Affected
- <= 1.19.1
- Fixed in
- 1.19.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qr93-8wwf-22g4 lists affected ranges: npm @finos/git-proxy >=0 <1.19.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qr93-8wwf-22g4 lists affected ranges: npm @finos/git-proxy >=0 <=1.19.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2025-54583: 0.53% estimated exploitation activity in the next 30 days; percentile 44.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This vulnerability allows a user to push to the remote repository while bypassing policies and explicit approval. Since checks and plugins are skipped, code containing secrets or unwanted changes could be pushed into a repository. Because it can allow policy violations to go undetected, we classify this as a High impact vulnerability. Details The source of the vulnerability is the push parser action parsePush.ts. It reads the first branch and parses it, while ignoring subsequent branches (silently letting them go through). Although the fix involves multiple improvements to the commit and push parsing logic, the core solution is to prevent multiple branch pushes from going through in the first place: PoC 1. Make a commit on a branch: 2. Wait for approval of safe-branch. 3. Make a commit on a separate branch with a secret, for example: 4. Push both at the same time: git push proxy safe-branch bad-branch Expected Result Ideally, this would force checks to run for the second…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qr93-8wwf-22g4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qr93-8wwf-22g4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54583 Advisory: GitProxy Approval Bypass When Pushing Multiple Branches IDs: CVE-2025-54583, GHSA-qr93-8wwf-22g4 Record: https://patchnext.com/advisories/cve-2025-54583 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @finos/git-proxy 1.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @finos/git-proxy: affected <= 1.19.1; fixed in 1.19.2 ## Suggested inspection (read-only) - `npm ls @finos/git-proxy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @finos/git-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qr93-8wwf-22g4 (OSV record GHSA-qr93-8wwf-22g4 lists affected ranges: npm @finos/git-proxy >=0 <1.19.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qr93-8wwf-22g4 (GitHub-reviewed advisory GHSA-qr93-8wwf-22g4 lists affected ranges: npm @finos/git-proxy >=0 <=1.19.1) Commands are suggestions: review each one before running it.
Loading voting…