Apache Airflow: RCE by race condition in example_xcom dag
CVE-2025-54550GHSA-q2hg-643c-gw8h
Withdrawn: the source no longer stands behind this advisory.
What to do
The source withdrew this advisory. Do not act on it without new evidence.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 3.2.0
- Fixed in
- 3.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q2hg-643c-gw8h lists affected ranges: PyPI apache-airflow >=0 <3.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2hg-643c-gw8h lists affected ranges: PyPI apache-airflow >=0 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
ghsa record GHSA-q2hg-643c-gw8h is marked withdrawn upstream (as of 2026-11-03T17:39:31Z).
VerifiedObserved Structured upstream record carries a withdrawn timestamp; no other upstream record still contributes.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-54550: 0.58% estimated exploitation activity in the next 30 days; percentile 47.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The example examplexcom that was included in airflow documentation implemented unsafe pattern of reading value from xcom in the way that could be exploited to allow UI user who had access to modify XComs to perform arbitrary execution of code on the worker. Since the UI users are already highly trusted, this is a Low severity vulnerability. It does not affect Airflow release - exampledags are not supposed to be enabled in production environment, however users following the example could replicate the bad pattern. Documentation of Airflow 3.2.0 contains version of the example with improved resiliance for that case. Users who followed that pattern are advised to adjust their implementations accordingly.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · withdrawn ·
Withdrawn upstream: ghsa record GHSA-q2hg-643c-gw8h
- Revision 2 · amended ·
Amended from ghsa record GHSA-q2hg-643c-gw8h
- Revision 1 · created ·
Published from osv record GHSA-q2hg-643c-gw8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54550 Advisory: Apache Airflow: RCE by race condition in example_xcom dag IDs: CVE-2025-54550, GHSA-q2hg-643c-gw8h Record: https://patchnext.com/advisories/cve-2025-54550 (revision 3, source checked 3 Nov 2026, 18:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.0. A vendor fix does not mean a deployment is fixed. Status: WITHDRAWN upstream. Do not act on this record without new evidence. ## Affected components - PyPI apache-airflow: affected < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q2hg-643c-gw8h (OSV record GHSA-q2hg-643c-gw8h lists affected ranges: PyPI apache-airflow >=0 <3.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q2hg-643c-gw8h (GitHub-reviewed advisory GHSA-q2hg-643c-gw8h lists affected ranges: PyPI apache-airflow >=0 <3.2.0) - Verified: https://github.com/advisories/GHSA-q2hg-643c-gw8h (ghsa record GHSA-q2hg-643c-gw8h is marked withdrawn upstream (as of 2026-11-03T17:39:31Z).) Commands are suggestions: review each one before running it.
Loading voting…