Skip to content

← Actionable
Critical, CVSS 9.8

Apache ActiveMQ NMS AMQP Client has a Deserialization of Untrusted Data vulnerability

CVE-2025-54539GHSA-4mjw-xr5x-prpc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache.nms.amqp 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-54539: 2.09% estimated exploitation activity in the next 30 days; percentile 81.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Deserialization of Untrusted Data vulnerability exists in the Apache ActiveMQ NMS AMQP Client. This issue affects all versions of Apache ActiveMQ NMS AMQP up to and including 2.3.0, when establishing connections to untrusted AMQP servers. Malicious servers could exploit unbounded deserialization logic present in the client to craft responses that may lead to arbitrary code execution on the client side. Although version 2.1.0 introduced a mechanism to restrict deserialization via allow/deny lists, the protection was found to be bypassable under certain conditions. In line with Microsoft’s deprecation of binary serialization in .NET 9, the project is evaluating the removal of .NET binary serialization support from the NMS API entirely in future releases. Mitigation and Recommendations: Users are strongly encouraged to upgrade to version 2.4.0 or later, which resolves the issue. Additionally, projects depending on NMS-AMQP should migrate away from .NET binary serialization as part of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4mjw-xr5x-prpc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54539

Advisory: Apache ActiveMQ NMS AMQP Client has a Deserialization of Untrusted Data vulnerability
IDs: CVE-2025-54539, GHSA-4mjw-xr5x-prpc
Record: https://patchnext.com/advisories/cve-2025-54539 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache.nms.amqp 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet apache.nms.amqp: affected < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- NuGet apache.nms.amqp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache.nms.amqp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mjw-xr5x-prpc (GitHub-reviewed advisory GHSA-4mjw-xr5x-prpc lists affected ranges: NuGet apache.nms.amqp >=0 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…