Skip to content

← Actionable
High, CVSS 7.1amended

Bugsink path traversal via event_id in ingestion

CVE-2025-54433GHSA-q78p-g86f-jg6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bugsink 1.7.4, 1.6.4, 1.5.5, 1.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bugsink

    Affected
    >= 1.7.0, < 1.7.4>= 1.6.0, < 1.6.4>= 1.5.0, < 1.5.5< 1.4.3
    Fixed in
    1.6.4, 1.7.4, 1.4.3, 1.5.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-54433: 0.66% estimated exploitation activity in the next 30 days; percentile 51.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions, ingestion paths construct file locations directly from untrusted eventid input without validation. A specially crafted eventid can result in paths outside the intended directory, potentially allowing file overwrite or creation in arbitrary locations. Submitting such input requires access to a valid DSN. While that limits exposure, DSNs are sometimes discoverable—for example, when included in frontend code—and should not be treated as a strong security boundary. Impact A valid DSN holder can craft an eventid that causes the ingestion process to write files outside its designated directory. This allows overwriting files accessible to the user running Bugsink. If Bugsink runs in a container, the effect is confined to the container’s filesystem. In non-containerized setups, the overwrite may affect other parts of the system accessible to that user. Mitigation Update to version 1.7.4, 1.6.4, 1.5.5 or 1.4.3 , which require eventid to be a valid UUID and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q78p-g86f-jg6q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q78p-g86f-jg6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54433

Advisory: Bugsink path traversal via event_id in ingestion
IDs: CVE-2025-54433, GHSA-q78p-g86f-jg6q
Record: https://patchnext.com/advisories/cve-2025-54433 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bugsink 1.7.4, 1.6.4, 1.5.5, 1.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bugsink: affected >= 1.7.0, < 1.7.4; >= 1.6.0, < 1.6.4; >= 1.5.0, < 1.5.5; < 1.4.3; fixed in 1.6.4, 1.7.4, 1.4.3, 1.5.5

## Suggested inspection (read-only)
- `python -m pip show bugsink`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bugsink.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q78p-g86f-jg6q (OSV record GHSA-q78p-g86f-jg6q lists affected ranges: PyPI bugsink >=1.7.0 =1.6.0 =1.5.0 =0 <1.4.3 (fixed))
- Verified: https://github.com/advisories/GHSA-q78p-g86f-jg6q (GitHub-reviewed advisory GHSA-q78p-g86f-jg6q lists affected ranges: PyPI bugsink >=1.7.0 =1.6.0 =1.5.0 =0 <1.4.3)

Commands are suggestions: review each one before running it.

Loading voting…