Skip to content

← Actionable
Critical, CVSS 10.0amended

Node-SAML SAML Signature Verification Vulnerability

CVE-2025-54419GHSA-4mxg-3p6v-xgq3

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @node-saml/node-saml

    Affected
    <= 5.0.1
    Fixed in
    5.1.0
  • npm passport-saml

    Affected
    <= 3.2.4
    Fixed in
    no fixed version recorded
  • npm @node-saml/passport-saml

    Affected
    <= 5.0.1
    Fixed in
    5.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2025-54419: 0.38% estimated exploitation activity in the next 30 days; percentile 31.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). In fixing this we made sure to process the SAML assertions from only verified/authenticated contents. This will prevent future variants from coming up. Note: this is distinct from the previous xml-crypto CVEs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4mxg-3p6v-xgq3

  2. Revision 1 · created ·

    Published from osv record GHSA-4mxg-3p6v-xgq3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54419

Advisory: Node-SAML SAML Signature Verification Vulnerability
IDs: CVE-2025-54419, GHSA-4mxg-3p6v-xgq3
Record: https://patchnext.com/advisories/cve-2025-54419 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @node-saml/node-saml 5.1.0; @node-saml/passport-saml 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @node-saml/node-saml: affected <= 5.0.1; fixed in 5.1.0
- npm passport-saml: affected <= 3.2.4
- npm @node-saml/passport-saml: affected <= 5.0.1; fixed in 5.1.0

## Suggested inspection (read-only)
- `npm ls @node-saml/node-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls passport-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @node-saml/passport-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @node-saml/node-saml, passport-saml, @node-saml/passport-saml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4mxg-3p6v-xgq3 (OSV record GHSA-4mxg-3p6v-xgq3 lists affected ranges: npm @node-saml/node-saml >=0 =0 =0 <5.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4mxg-3p6v-xgq3 (GitHub-reviewed advisory GHSA-4mxg-3p6v-xgq3 lists affected ranges: npm @node-saml/node-saml >=0 =0 =0 <=5.0.1)

Commands are suggestions: review each one before running it.

Loading voting…