Skip to content

← Actionable
High, CVSS 8.7amended

Skops may allow MethodNode to access unexpected object fields through dot notation, leading to arbitrary code execution at load time

CVE-2025-54413GHSA-4v6w-xpmh-gfgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (skops 0.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI skops

    Affected
    < 0.12.0
    Fixed in
    0.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-54413: 0.16% estimated exploitation activity in the next 30 days; percentile 5.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An inconsistency in MethodNode can be exploited to access unexpected object fields through dot notation. This can be used to achieve arbitrary code execution at load time. While this issue may seem similar to https://github.com/skops-dev/skops/security/advisories/GHSA-m7f4-hrc6-fwg3, it is actually more severe, as it relies on fewer assumptions about trusted types. Details The MethodNode allows access to attributes of existing objects via dot notation. However, there are several critical shortcomings: Although the class and module fields are checked via getuntrustedtypes and during the load phase (as a concatenated string), they are not actually used by MethodNode. Instead, the func and obj entries in the schema.json are used to determine behavior. This means that even an apparently harmless module.class pair can lead to access of arbitrary attributes or methods of loaded objects, without any additional checks. Nothing prevents an attacker from chaining multiple MethodNode…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4v6w-xpmh-gfgp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4v6w-xpmh-gfgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54413

Advisory: Skops may allow MethodNode to access unexpected object fields through dot notation, leading to arbitrary code execution at load time
IDs: CVE-2025-54413, GHSA-4v6w-xpmh-gfgp
Record: https://patchnext.com/advisories/cve-2025-54413 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: skops 0.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI skops: affected < 0.12.0; fixed in 0.12.0

## Suggested inspection (read-only)
- `python -m pip show skops`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on skops.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4v6w-xpmh-gfgp (OSV record GHSA-4v6w-xpmh-gfgp lists affected ranges: PyPI skops >=0 <0.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4v6w-xpmh-gfgp (GitHub-reviewed advisory GHSA-4v6w-xpmh-gfgp lists affected ranges: PyPI skops >=0 <0.12.0)

Commands are suggestions: review each one before running it.

Loading voting…