Skops has Inconsistent Trusted Type Validation that Enables Hidden operator Methods Execution
CVE-2025-54412GHSA-m7f4-hrc6-fwg3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (skops 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI skops
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m7f4-hrc6-fwg3 lists affected ranges: PyPI skops >=0 <0.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m7f4-hrc6-fwg3 lists affected ranges: PyPI skops >=0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-54412: 0.16% estimated exploitation activity in the next 30 days; percentile 5.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An inconsistency in OperatorFuncNode can be exploited to hide the execution of untrusted operator.xxx methods. This can then be used in a code reuse attack to invoke seemingly safe functions and escalate to arbitrary code execution with minimal and misleading trusted types. Note: This report focuses on operator.call as it appears to be the most interesting target, but the same technique applies to other operator methods. Moreover, focusing on a specific example is not necessary, the operator.call invocation was a zero-effort choice meant solely to demonstrate the issue. The key point is the inconsistency that allows a user to approve a type as trusted, while in reality enabling the execution of operator.xxx. Details The OperatorFuncNode allows calling methods belonging to the operator module and included in a trusted list of methods. However, what is returned by getuntrustedtypes and checked during the load call is not exactly the same as what is actually called. Instead, it…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m7f4-hrc6-fwg3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m7f4-hrc6-fwg3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54412 Advisory: Skops has Inconsistent Trusted Type Validation that Enables Hidden `operator` Methods Execution IDs: CVE-2025-54412, GHSA-m7f4-hrc6-fwg3 Record: https://patchnext.com/advisories/cve-2025-54412 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: skops 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI skops: affected < 0.12.0; fixed in 0.12.0 ## Suggested inspection (read-only) - `python -m pip show skops`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on skops. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m7f4-hrc6-fwg3 (OSV record GHSA-m7f4-hrc6-fwg3 lists affected ranges: PyPI skops >=0 <0.12.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m7f4-hrc6-fwg3 (GitHub-reviewed advisory GHSA-m7f4-hrc6-fwg3 lists affected ranges: PyPI skops >=0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…