Skip to content

← Actionable
Low, CVSS 3.3

Moby firewalld reload removes bridge network isolation

CVE-2025-54410GHSA-4vq8-7jfc-9cvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 28.0.0, 25.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-54410: 0.18% estimated exploitation activity in the next 30 days; percentile 7.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moby is an open source container framework developed by Docker Inc. that is distributed as Docker Engine, Mirantis Container Runtime, and various other downstream projects/products. The Moby daemon component (dockerd), which is developed as moby/moby is commonly referred to as Docker, or Docker Engine. Firewalld is a daemon used by some Linux distributions to provide a dynamically managed firewall. When Firewalld is running, Docker uses its iptables backend to create rules, including rules to isolate containers in one bridge network from containers in other bridge networks. Impact The iptables rules created by Docker are removed when firewalld is reloaded using, for example "firewall-cmd --reload", "killall -HUP firewalld", or "systemctl reload firewalld". When that happens, Docker must re-create the rules. However, in affected versions of Docker, the iptables rules that isolate containers in different bridge networks from each other are not re-created. Once these rules have been…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4vq8-7jfc-9cvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54410

Advisory: Moby firewalld reload removes bridge network isolation
IDs: CVE-2025-54410, GHSA-4vq8-7jfc-9cvp
Record: https://patchnext.com/advisories/cve-2025-54410 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 28.0.0, 25.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected <= 25.0.12; >= 26.0.0-rc1, < 28.0.0; fixed in 25.0.13, 28.0.0

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4vq8-7jfc-9cvp (GitHub-reviewed advisory GHSA-4vq8-7jfc-9cvp lists affected ranges: Go github.com/docker/docker >=0 =26.0.0-rc1 <28.0.0)

Commands are suggestions: review each one before running it.

Loading voting…