Skip to content

← Actionable
Medium, CVSS 6.3amended

CKAN vulnerable to stored XSS in resource description

CVE-2025-54384GHSA-2r4h-8jxv-w2j8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.11.4, 2.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ckan

    Affected
    >= 2.11.0, < 2.11.4< 2.10.9
    Fixed in
    2.10.9, 2.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2025-54384: 0.23% estimated exploitation activity in the next 30 days; percentile 13.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The helpers.markdownextract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. Patches This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2r4h-8jxv-w2j8

  2. Revision 1 · created ·

    Published from osv record GHSA-2r4h-8jxv-w2j8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54384

Advisory: CKAN vulnerable to stored XSS in resource description
IDs: CVE-2025-54384, GHSA-2r4h-8jxv-w2j8
Record: https://patchnext.com/advisories/cve-2025-54384 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckan 2.11.4, 2.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ckan: affected >= 2.11.0, < 2.11.4; < 2.10.9; fixed in 2.10.9, 2.11.4

## Suggested inspection (read-only)
- `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2r4h-8jxv-w2j8 (OSV record GHSA-2r4h-8jxv-w2j8 lists affected ranges: PyPI ckan >=2.11.0 =0 <2.10.9 (fixed))
- Verified: https://github.com/advisories/GHSA-2r4h-8jxv-w2j8 (GitHub-reviewed advisory GHSA-2r4h-8jxv-w2j8 lists affected ranges: PyPI ckan >=2.11.0 =0 <2.10.9)

Commands are suggestions: review each one before running it.

Loading voting…