Skip to content

← Actionable
High, CVSS 8.9amended

eKuiper API endpoints handling SQL queries with user-controlled table names.

CVE-2025-54379GHSA-526j-mv3p-f4vv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ekuiper

    Affected
    <= 2.1.5
    Fixed in
    no fixed version recorded
  • Go github.com/lf-edge/ekuiper/v2

    Affected
    < 2.2.1
    Fixed in
    2.2.1
  • Go github.com/lf-edge/ekuiper

    Affected
    <= 1.14.7
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-54379: 0.87% estimated exploitation activity in the next 30 days; percentile 58.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A critical SQL Injection vulnerability exists in the getLast API functionality of the eKuiper project. This flaw allows unauthenticated remote attackers to execute arbitrary SQL statements on the underlying SQLite database by manipulating the table name input in an API request. Exploitation can lead to data theft, corruption, or deletion, and full database compromise. Details The root cause lies in the use of unsanitized user-controlled input when constructing SQL queries using fmt.Sprintf, without validating the table parameter. Specifically, in: Any value passed as the table parameter is directly interpolated into the SQL string, enabling injection attacks. This is reachable via API interfaces that expose time-series queries. PoC 1. Deploy eKuiper instance (default config is sufficient). 2. Send a crafted request to the SQL query endpoint: 3. Effect: Executes two SQL queries — the first selects data, the second drops the users table. 4. Verify Result: Impact CWE-89:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-526j-mv3p-f4vv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record PYSEC-2025-241

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54379

Advisory: eKuiper API endpoints handling SQL queries with user-controlled table names.
IDs: CVE-2025-54379, GHSA-526j-mv3p-f4vv
Record: https://patchnext.com/advisories/cve-2025-54379 (revision 3, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/lf-edge/ekuiper/v2 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ekuiper: affected <= 2.1.5
- Go github.com/lf-edge/ekuiper/v2: affected < 2.2.1; fixed in 2.2.1
- Go github.com/lf-edge/ekuiper: affected <= 1.14.7

## Suggested inspection (read-only)
- `python -m pip show ekuiper`: prints the installed version. Run with the environment that serves production active.
- Go github.com/lf-edge/ekuiper/v2: check the installed version with your package manager.
- Go github.com/lf-edge/ekuiper: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ekuiper, github.com/lf-edge/ekuiper/v2, github.com/lf-edge/ekuiper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2025-241 (OSV record PYSEC-2025-241 lists affected ranges: PyPI ekuiper >=0 <=2.1.5)
- Verified: https://github.com/advisories/GHSA-526j-mv3p-f4vv (GitHub-reviewed advisory GHSA-526j-mv3p-f4vv lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 =0 <=1.14.7)

Commands are suggestions: review each one before running it.

Loading voting…