Skip to content

← Actionable
High, CVSS 8.3amended

HAX CMS API Lacks Authorization Checks

CVE-2025-54378GHSA-9jr9-8ff3-m894

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.14; elmsln/haxcms 11.0.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
EPSS
  • CVE-2025-54378: 0.57% estimated exploitation activity in the next 30 days; percentile 47.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The HAX CMS API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. Details The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. Affected Resources - Operations.php: 760 createNode() - Operations.php: 868 saveNode() - Operations.php: 1171 deleteNode() - Operations.php: 1789 listSites() - Operations.php: 1890 createSite() - Operations.php: 2196 getConfig() - Operations.php: 2389 cloneSite() - Operations.php: 2467 deleteSite() - Operations.php: 2524 downloadSite() - Operations.php: 2607 archiveSite() Note: This may not include all affected endpoints within the application. Impact An authenticated attacker can make requests to interact with other users' sites. This can be used to enumerate, modify, and delete…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9jr9-8ff3-m894

  2. Revision 1 · created ·

    Published from osv record GHSA-9jr9-8ff3-m894

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54378

Advisory: HAX CMS API Lacks Authorization Checks
IDs: CVE-2025-54378, GHSA-9jr9-8ff3-m894
Record: https://patchnext.com/advisories/cve-2025-54378 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.14; elmsln/haxcms 11.0.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/haxcms-nodejs: affected < 11.0.14; fixed in 11.0.14
- Packagist elmsln/haxcms: affected < 11.0.14; fixed in 11.0.14

## Suggested inspection (read-only)
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Packagist elmsln/haxcms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/haxcms-nodejs, elmsln/haxcms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jr9-8ff3-m894 (OSV record GHSA-9jr9-8ff3-m894 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <11.0.14 (fixed))
- Verified: https://github.com/advisories/GHSA-9jr9-8ff3-m894 (GitHub-reviewed advisory GHSA-9jr9-8ff3-m894 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <11.0.14)

Commands are suggestions: review each one before running it.

Loading voting…