PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser
CVE-2025-54370GHSA-rx7m-68vc-ppxh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.0.0, 3.10.0, 2.4.0, 2.1.12, 1.30.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpspreadsheet
- Affected
- < 1.30.0>= 2.0.0, < 2.1.12>= 2.2.0, < 2.4.0>= 3.0.0, < 3.10.0>= 4.0.0, < 5.0.0
- Fixed in
- 2.4.0, 2.1.12, 1.30.0, 3.10.0, 5.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rx7m-68vc-ppxh lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =2.0.0 =2.2.0 =3.0.0 =4.0.0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54370: 0.82% estimated exploitation activity in the next 30 days; percentile 57.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Product: PhpSpreadsheet Version: 3.8.0 CWE-ID: CWE-918: Server-Side Request Forgery (SSRF) CVSS vector v.3.1: 7.5 (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N) CVSS vector v.4.0: 8.7 (AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N) Description: SSRF occurs when a processed HTML document is read and displayed in the browser Impact: Server-Side Request Forgery Vulnerable component: the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, setPath method Exploitation conditions: getting a string from the user that is passed to the HTML reader Mitigation: improved processing of the $path variable of the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class is needed Researcher: Aleksey Solovev (Positive Technologies) Research The researcher discovered zero-day vulnerability Server-Side Request Forgery (SSRF) (in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class) in Phpspreadsheet. The latest version (3.8.0) of the phpoffice/phpspreadsheet library was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rx7m-68vc-ppxh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54370 Advisory: PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser IDs: CVE-2025-54370, GHSA-rx7m-68vc-ppxh Record: https://patchnext.com/advisories/cve-2025-54370 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.0.0, 3.10.0, 2.4.0, 2.1.12, 1.30.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpspreadsheet: affected < 1.30.0; >= 2.0.0, < 2.1.12; >= 2.2.0, < 2.4.0; >= 3.0.0, < 3.10.0; >= 4.0.0, < 5.0.0; fixed in 2.4.0, 2.1.12, 1.30.0, 3.10.0, 5.0.0 ## Suggested inspection (read-only) - Packagist phpoffice/phpspreadsheet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpspreadsheet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rx7m-68vc-ppxh (GitHub-reviewed advisory GHSA-rx7m-68vc-ppxh lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =2.0.0 =2.2.0 =3.0.0 =4.0.0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…