pyLoad has Path Traversal Vulnerability in json/upload Endpoint that allows Arbitrary File Write
CVE-2025-54140GHSA-xqpg-92fq-grfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev90), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyload-ng
- Affected
- >= 0.5.0b3.dev89, <= 0.5.0b3.dev89
- Fixed in
- 0.5.0b3.dev90
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xqpg-92fq-grfg lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev89 <0.5.0b3.dev90 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqpg-92fq-grfg lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev89 <=0.5.0b3.dev89
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-54140: 0.75% estimated exploitation activity in the next 30 days; percentile 55.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated path traversal vulnerability exists in the /json/upload endpoint of the pyLoad By manipulating the filename of an uploaded file, an attacker can traverse out of the intended upload directory, allowing them to write arbitrary files to any location on the system accessible to the pyLoad process. This may lead to: Remote Code Execution (RCE) Local Privilege Escalation System-wide compromise Persistence and backdoors --- Vulnerable Code File: src/pyload/webui/app/blueprints/jsonblueprint.py Issue: No sanitization or validation on file.filename, allowing traversal via ../../ sequences. (Proof of Concept) 1. Clone and install pyLoad from source (pip install pyload-ng): 2. Or install via pip (PyPi) in virtualenv: 1. Login and obtain session token 2. Create malicious cron payload 3. Upload file with path traversal filename 4. On the next cron tick, a reverse shell or payload will be triggered. BurpSuite HTTP Request
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xqpg-92fq-grfg
- Revision 1 · created ·
Published from osv record GHSA-xqpg-92fq-grfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54140 Advisory: `pyLoad` has Path Traversal Vulnerability in `json/upload` Endpoint that allows Arbitrary File Write IDs: CVE-2025-54140, GHSA-xqpg-92fq-grfg Record: https://patchnext.com/advisories/cve-2025-54140 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev90. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyload-ng: affected >= 0.5.0b3.dev89, <= 0.5.0b3.dev89; fixed in 0.5.0b3.dev90 ## Suggested inspection (read-only) - `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyload-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xqpg-92fq-grfg (OSV record GHSA-xqpg-92fq-grfg lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev89 <0.5.0b3.dev90 (fixed)) - Verified: https://github.com/advisories/GHSA-xqpg-92fq-grfg (GitHub-reviewed advisory GHSA-xqpg-92fq-grfg lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev89 <=0.5.0b3.dev89) Commands are suggestions: review each one before running it.
Loading voting…