Skip to content

← Actionable
Medium, CVSS 4.3amended

HAX CMS application pages vulnerable to clickjacking

CVE-2025-54139GHSA-54vw-f4xf-f92j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.13; elmsln/haxcms 11.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-54139: 0.36% estimated exploitation activity in the next 30 days; percentile 29.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary All pages within the HAX CMS application do not contain headers to stop other websites from loading the site within an iframe. This applies to both the CMS and generated sites. PoC To replicate this vulnerability, load the target page in an iframe and observe the rendered content. Impact An unauthenticated attacker can load the standalone login page or other sensitive functionality within an iframe, performing a UI redressing attack (Clickjacking). This can be used to perform social engineering attacks to attempt to coerce users into performing unintended actions within the HAX CMS application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-54vw-f4xf-f92j

  2. Revision 1 · created ·

    Published from osv record GHSA-54vw-f4xf-f92j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54139

Advisory: HAX CMS application pages vulnerable to clickjacking
IDs: CVE-2025-54139, GHSA-54vw-f4xf-f92j
Record: https://patchnext.com/advisories/cve-2025-54139 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.13; elmsln/haxcms 11.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/haxcms-nodejs: affected < 11.0.13; fixed in 11.0.13
- Packagist elmsln/haxcms: affected < 11.0.8; fixed in 11.0.8

## Suggested inspection (read-only)
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Packagist elmsln/haxcms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/haxcms-nodejs, elmsln/haxcms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-54vw-f4xf-f92j (OSV record GHSA-54vw-f4xf-f92j lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <11.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-54vw-f4xf-f92j (GitHub-reviewed advisory GHSA-54vw-f4xf-f92j lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <11.0.8)

Commands are suggestions: review each one before running it.

Loading voting…