HAX CMS NodeJS Application Has Improper Error Handling That Leads to Denial of Service
CVE-2025-54134GHSA-pjj3-j5j6-qj27
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 11.0.9
- Fixed in
- 11.0.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjj3-j5j6-qj27 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjj3-j5j6-qj27 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54134: 0.47% estimated exploitation activity in the next 30 days; percentile 40.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. Details This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. Affected Resources • listFiles.js:22 listFiles() • saveFile.js:52 saveFile() • system/api/listFiles • system/api/saveFile PoC 1. Targeting an instance of instance of HAX CMS NodeJS, send a request without parameters to listFiles or saveFiles. The following screenshot shows the request in Burp Suite. 2. The server will crash with ERRINVALIDARGTYPE. Impact An authenticated attacker can deny access to the HAX CMS NodeJS application by crashing the backend server. This prevents all users from accessing the backend system. If the backend system is hosting websites, those websites will be unavailable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pjj3-j5j6-qj27
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pjj3-j5j6-qj27
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54134 Advisory: HAX CMS NodeJS Application Has Improper Error Handling That Leads to Denial of Service IDs: CVE-2025-54134, GHSA-pjj3-j5j6-qj27 Record: https://patchnext.com/advisories/cve-2025-54134 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @haxtheweb/haxcms-nodejs: affected < 11.0.9; fixed in 11.0.9 ## Suggested inspection (read-only) - `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @haxtheweb/haxcms-nodejs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjj3-j5j6-qj27 (OSV record GHSA-pjj3-j5j6-qj27 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.9 (fixed)) - Verified: https://github.com/advisories/GHSA-pjj3-j5j6-qj27 (GitHub-reviewed advisory GHSA-pjj3-j5j6-qj27 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.9) Commands are suggestions: review each one before running it.
Loading voting…