NodeJS version of HAX CMS Has Insecure Default Configuration That Leads to Unauthenticated Access
CVE-2025-54127GHSA-f38f-jvqj-mfg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 11.0.6
- Fixed in
- 11.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f38f-jvqj-mfg6 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f38f-jvqj-mfg6 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <=11.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54127: 0.46% estimated exploitation activity in the next 30 days; percentile 39.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The NodeJS version of HAX CMS uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. Details If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMSDISABLEJWTCHECKS‘ would be set to ‘true‘ and their deployment would lack session authentication. Affected Resources - package.json:13 PoC To reproduce this vulnerability, install HAX CMS NodeJS. The application will load without JWT checks enabled. Impact Without security checks in place, an unauthenticated remote attacker could access, modify, and delete all site information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f38f-jvqj-mfg6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f38f-jvqj-mfg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54127 Advisory: NodeJS version of HAX CMS Has Insecure Default Configuration That Leads to Unauthenticated Access IDs: CVE-2025-54127, GHSA-f38f-jvqj-mfg6 Record: https://patchnext.com/advisories/cve-2025-54127 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @haxtheweb/haxcms-nodejs: affected <= 11.0.6; fixed in 11.0.7 ## Suggested inspection (read-only) - `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @haxtheweb/haxcms-nodejs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f38f-jvqj-mfg6 (OSV record GHSA-f38f-jvqj-mfg6 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.7 (fixed)) - Verified: https://github.com/advisories/GHSA-f38f-jvqj-mfg6 (GitHub-reviewed advisory GHSA-f38f-jvqj-mfg6 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <=11.0.6) Commands are suggestions: review each one before running it.
Loading voting…