XWiki exposes passwords and emails stored in fields not named password/email in xml.vm
CVE-2025-54125GHSA-57q2-6cp4-9mq3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 17.2.0-rc-1, 16.10.5, 16.4.7; org.xwiki.platform:xwiki-platform-legacy-oldcore 17.2.0-rc-1, 16.10.5, 16.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 1.1, < 16.4.7>= 16.5.0-rc-1, < 16.10.5>= 17.0.0-rc-1, < 17.2.0-rc-1
- Fixed in
- 17.2.0-rc-1, 16.10.5, 16.4.7
Maven org.xwiki.platform:xwiki-platform-legacy-oldcore
- Affected
- >= 1.1, < 16.4.7>= 16.5.0-rc-1, < 16.10.5>= 17.0.0-rc-1, < 17.2.0-rc-1
- Fixed in
- 17.2.0-rc-1, 16.10.5, 16.4.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57q2-6cp4-9mq3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.1 =16.5.0-rc-1 =17.0.0-rc-1 =1.1 =16.5.0-rc-1 =17.0.0-rc-1 <17.2.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54125: 1.45% estimated exploitation activity in the next 30 days; percentile 73.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The XML export of a page in XWiki that can be triggered by any user with view rights on a page by appending ?xpage=xml to the URL includes password and email properties stored on a document that aren't named password or email. This allows any user to obtain the salted and hashed user account validation or password reset token. As those tokens are randomly generated strings, the immediate impact of this should be low. The user's password and email itself aren't exposed as those fields are named password and email and thus aren't affected. However, depending on how the wiki is used, there could be extensions or custom code that store passwords in plain text in such password properties that would be exposed by this vulnerability. Patches This vulnerability has been fixed by completely removing the output of password and email fields in this XML export in versions 17.2.0 RC1, 16.10.5 and 16.4.7. Workarounds If this XML export isn't needed, the file templates/xml.vm in the deployed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-57q2-6cp4-9mq3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54125 Advisory: XWiki exposes passwords and emails stored in fields not named password/email in xml.vm IDs: CVE-2025-54125, GHSA-57q2-6cp4-9mq3 Record: https://patchnext.com/advisories/cve-2025-54125 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 17.2.0-rc-1, 16.10.5, 16.4.7; org.xwiki.platform:xwiki-platform-legacy-oldcore 17.2.0-rc-1, 16.10.5, 16.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 1.1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.5; >= 17.0.0-rc-1, < 17.2.0-rc-1; fixed in 17.2.0-rc-1, 16.10.5, 16.4.7 - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: affected >= 1.1, < 16.4.7; >= 16.5.0-rc-1, < 16.10.5; >= 17.0.0-rc-1, < 17.2.0-rc-1; fixed in 17.2.0-rc-1, 16.10.5, 16.4.7 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore, org.xwiki.platform:xwiki-platform-legacy-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-57q2-6cp4-9mq3 (GitHub-reviewed advisory GHSA-57q2-6cp4-9mq3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.1 =16.5.0-rc-1 =17.0.0-rc-1 =1.1 =16.5.0-rc-1 =17.0.0-rc-1 <17.2.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…