The ADOdb sqlite3 driver allows SQL injection
CVE-2025-54119GHSA-vf2r-cxg9-p7rf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (adodb/adodb-php 5.22.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist adodb/adodb-php
- Affected
- <= 5.22.9
- Fixed in
- 5.22.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf2r-cxg9-p7rf lists affected ranges: Packagist adodb/adodb-php >=0 <=5.22.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2025-54119: 0.53% estimated exploitation activity in the next 30 days; percentile 45.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. Note that the indicated Severity corresponds to a worst-case usage scenario, e.g. allowing user-supplied data to be sent as-is to the above-mentioned methods. Impact SQLite3 driver. Patches Vulnerability is fixed in ADOdb 5.22.10 (https://github.com/ADOdb/ADOdb/commit/5b8bd52cdcffefb4ecded1b399c98cfa516afe03). Workarounds Only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter. Credits Thanks to Marco Nappi (@mrcnpp) for reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vf2r-cxg9-p7rf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54119 Advisory: The ADOdb sqlite3 driver allows SQL injection IDs: CVE-2025-54119, GHSA-vf2r-cxg9-p7rf Record: https://patchnext.com/advisories/cve-2025-54119 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: adodb/adodb-php 5.22.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist adodb/adodb-php: affected <= 5.22.9; fixed in 5.22.10 ## Suggested inspection (read-only) - Packagist adodb/adodb-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on adodb/adodb-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vf2r-cxg9-p7rf (GitHub-reviewed advisory GHSA-vf2r-cxg9-p7rf lists affected ranges: Packagist adodb/adodb-php >=0 <=5.22.9) Commands are suggestions: review each one before running it.
Loading voting…