Exiv2 Segmentation Faults in Exiv2::EpsImage::writeMetadata() via crafted EPS file
CVE-2025-54080GHSA-496f-x7cq-cq39
What to do
Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI exiv2
- Affected
- <= 0.17.3
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-496f-x7cq-cq39 lists affected ranges: PyPI exiv2 >=0 <=0.17.3
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-496f-x7cq-cq39 lists affected ranges: PyPI exiv2 >=0 <=0.17.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54080: 0.14% estimated exploitation activity in the next 30 days; percentile 3.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An out-of-bounds read was found in Exiv2 versions v0.28.5 and earlier. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as delete. Patches The bug is fixed in version v0.28.6. Credit Thank you to @dragonArthurX for reporting this issue. Details (from original report by @dragonArthurX ) Version: Tested on v0.28.5 (latest official release) Commit:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-496f-x7cq-cq39
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-496f-x7cq-cq39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54080 Advisory: Exiv2 Segmentation Faults in Exiv2::EpsImage::writeMetadata() via crafted EPS file IDs: CVE-2025-54080, GHSA-496f-x7cq-cq39 Record: https://patchnext.com/advisories/cve-2025-54080 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI exiv2: affected <= 0.17.3 ## Suggested inspection (read-only) - `python -m pip show exiv2`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on exiv2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-496f-x7cq-cq39 (OSV record GHSA-496f-x7cq-cq39 lists affected ranges: PyPI exiv2 >=0 <=0.17.3) - Verified: https://github.com/advisories/GHSA-496f-x7cq-cq39 (GitHub-reviewed advisory GHSA-496f-x7cq-cq39 lists affected ranges: PyPI exiv2 >=0 <=0.17.3) Commands are suggestions: review each one before running it.
Loading voting…