mcp-package-docs vulnerable to command injection in several tools
CVE-2025-54073GHSA-vf9j-h32g-2764
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-package-docs 0.1.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mcp-package-docs
- Affected
- <= 0.1.27
- Fixed in
- 0.1.28
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vf9j-h32g-2764 lists affected ranges: npm mcp-package-docs >=0 <0.1.28 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf9j-h32g-2764 lists affected ranges: npm mcp-package-docs >=0 <=0.1.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-54073: 11.29% estimated exploitation activity in the next 30 days; percentile 95.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A command injection vulnerability exists in the mcp-package-docs MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes tools to access documentation for several types of packages. An MCP Client can be instructed to execute additional actions for example via prompt injection when asked to read package documentation. Below some example of vulnerable code and different ways to test this vulnerability including a real example of indirect prompt injection that can lead to arbitrary command injection. Vulnerable code The following snippet…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vf9j-h32g-2764
- Revision 1 · created ·
Published from osv record GHSA-vf9j-h32g-2764
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54073 Advisory: mcp-package-docs vulnerable to command injection in several tools IDs: CVE-2025-54073, GHSA-vf9j-h32g-2764 Record: https://patchnext.com/advisories/cve-2025-54073 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-package-docs 0.1.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mcp-package-docs: affected <= 0.1.27; fixed in 0.1.28 ## Suggested inspection (read-only) - `npm ls mcp-package-docs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-package-docs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vf9j-h32g-2764 (OSV record GHSA-vf9j-h32g-2764 lists affected ranges: npm mcp-package-docs >=0 <0.1.28 (fixed)) - Verified: https://github.com/advisories/GHSA-vf9j-h32g-2764 (GitHub-reviewed advisory GHSA-vf9j-h32g-2764 lists affected ranges: npm mcp-package-docs >=0 <=0.1.27) Commands are suggestions: review each one before running it.
Loading voting…