Skip to content

← Actionable
Critical, CVSS 9.2Exploited · CISA KEV

Livewire is vulnerable to remote command execution during component property update hydration

CVE-2025-54068GHSA-29cq-5w36-x7w3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (livewire/livewire 3.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-54068: 96.28% estimated exploitation activity in the next 30 days; percentile 99.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Livewire v3 (≤ 3.6.3), a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. Patches This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. Workarounds There is no known workaround at this time. Users are strongly advised to upgrade to a patched version immediately. Resources No public references available at this time to avoid exposure. Details will be published after a responsible disclosure window.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29cq-5w36-x7w3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54068

Advisory: Livewire is vulnerable to remote command execution during component property update hydration
IDs: CVE-2025-54068, GHSA-29cq-5w36-x7w3
Record: https://patchnext.com/advisories/cve-2025-54068 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: livewire/livewire 3.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist livewire/livewire: affected >= 3.0.0-beta.1, < 3.6.4; fixed in 3.6.4

## Suggested inspection (read-only)
- Packagist livewire/livewire: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on livewire/livewire.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29cq-5w36-x7w3 (GitHub-reviewed advisory GHSA-29cq-5w36-x7w3 lists affected ranges: Packagist livewire/livewire >=3.0.0-beta.1 <3.6.4)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-54068 to the Known Exploited Vulnerabilities catalog on 2026-03-20.)

Commands are suggestions: review each one before running it.

Loading voting…