Mattermost Fails to Properly Validate Team Role Modification
CVE-2025-53971GHSA-4276-cm8c-788h
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250721095846-c602a4a78e1f
- Fixed in
- 8.0.0-20250721095846-c602a4a78e1f
Go github.com/mattermost/mattermost-server/v6
- Affected
- <= 6.7.2
- Fixed in
- no fixed version recorded
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.5.0, <= 10.5.8>= 9.11.0, <= 9.11.17
- Fixed in
- 10.5.9, 9.11.18
Go github.com/mattermost/mattermost-server/v5
- Affected
- <= 5.39.3
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4276-cm8c-788h lists affected ranges: Go github.com/mattermost/mattermost-server >=10.5.0 =9.11.0 =0 =0 =0 <=6.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-53971: 0.20% estimated exploitation activity in the next 30 days; percentile 10.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate authorization for team scheme role modifications which allows Team Admins to demote Team Members to Guests via the PUT /api/v4/teams/team-id/members/user-id/schemeRoles API endpoint.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4276-cm8c-788h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53971 Advisory: Mattermost Fails to Properly Validate Team Role Modification IDs: CVE-2025-53971, GHSA-4276-cm8c-788h Record: https://patchnext.com/advisories/cve-2025-53971 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250721095846-c602a4a78e1f; github.com/mattermost/mattermost-server 10.5.9, 9.11.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250721095846-c602a4a78e1f; fixed in 8.0.0-20250721095846-c602a4a78e1f - Go github.com/mattermost/mattermost-server/v6: affected <= 6.7.2 - Go github.com/mattermost/mattermost-server: affected >= 10.5.0, <= 10.5.8; >= 9.11.0, <= 9.11.17; fixed in 10.5.9, 9.11.18 - Go github.com/mattermost/mattermost-server/v5: affected <= 5.39.3 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4276-cm8c-788h (GitHub-reviewed advisory GHSA-4276-cm8c-788h lists affected ranges: Go github.com/mattermost/mattermost-server >=10.5.0 =9.11.0 =0 =0 =0 <=6.7.2) Commands are suggestions: review each one before running it.
Loading voting…