Skip to content

← Actionable
High, CVSS 7.0

apko is vulnerable to attack through incorrect permissions in /etc/ld.so.cache and other files

CVE-2025-53945GHSA-x6ph-r535-3vjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainguard.dev/apko 0.29.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L
EPSS
  • CVE-2025-53945: 0.14% estimated exploitation activity in the next 30 days; percentile 3.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

It was discovered that the ld.so.cache in images generated by apko had file system permissions mode 0666: This issue was introduced in commit 04f37e2 ("generate /etc/ld.so.cache (#1629)")(v0.27.0). Impact This potentially allows a local unprivileged user to add additional additional directories including dynamic libraries to the dynamic loader path. A user could exploit this by placing a malicious library in a directory they control. Patches This issue was addressed in apko in aedb077 ("fix: /etc/ld.so.cache file permissions (#1758)") (v0.29.5). Acknowledgements Many thanks to Cody Harris from H2O.ai for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x6ph-r535-3vjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53945

Advisory: apko is vulnerable to attack through incorrect permissions in /etc/ld.so.cache and other files
IDs: CVE-2025-53945, GHSA-x6ph-r535-3vjw
Record: https://patchnext.com/advisories/cve-2025-53945 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chainguard.dev/apko 0.29.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go chainguard.dev/apko: affected >= 0.27.0, < 0.29.5; fixed in 0.29.5

## Suggested inspection (read-only)
- Go chainguard.dev/apko: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chainguard.dev/apko.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x6ph-r535-3vjw (GitHub-reviewed advisory GHSA-x6ph-r535-3vjw lists affected ranges: Go chainguard.dev/apko >=0.27.0 <0.29.5)

Commands are suggestions: review each one before running it.

Loading voting…