Skip to content

← Actionable
Medium, CVSS 5.3amended

vue-i18n's escapeParameterHtml does not prevent DOM-based XSS through its tag attributes

CVE-2025-53892GHSA-x8qp-wqqm-57ph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@intlify/vue-i18n-core 11.1.10, 10.0.8, 9.14.5; vue-i18n 11.1.10, 10.0.8, 9.14.5; petite-vue-i18n 11.1.10, 10.0.8; @intlify/core-base 11.1.10, 10.0.8, 9.14.5; @intlify/core 11.1.10, 10.0.8, 9.14.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @intlify/vue-i18n-core

    Affected
    >= 9.2.0, < 9.14.5>= 10.0.0, < 10.0.8>= 11.0.0, < 11.1.10
    Fixed in
    9.14.5, 10.0.8, 11.1.10
  • npm vue-i18n

    Affected
    >= 9.0.0, < 9.14.5>= 10.0.0, < 10.0.8>= 11.0.0, < 11.1.10
    Fixed in
    9.14.5, 10.0.8, 11.1.10
  • npm petite-vue-i18n

    Affected
    >= 10.0.0, < 10.0.8>= 11.0.0, < 11.1.10
    Fixed in
    10.0.8, 11.1.10
  • npm @intlify/core-base

    Affected
    >= 9.0.0, < 9.14.5>= 10.0.0, < 10.0.8>= 11.0.0, < 11.1.10
    Fixed in
    9.14.5, 10.0.8, 11.1.10
  • npm @intlify/core

    Affected
    >= 9.0.0, < 9.14.5>= 10.0.0, < 10.0.8>= 11.0.0, < 11.1.10
    Fixed in
    9.14.5, 10.0.8, 11.1.10

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-x8qp-wqqm-57ph lists affected ranges: npm vue-i18n >=9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.2.0 =10.0.0 =11.0.0 =10.0.0 <10.0.8 (fixed),…

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-x8qp-wqqm-57ph lists affected ranges: npm vue-i18n >=9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.2.0 =10.0.0 =11.0.0 =10.0.0 =11.0.0 <11.1.10

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-53892: 0.81% estimated exploitation activity in the next 30 days; percentile 56.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The escapeParameterHtml: true option in Vue I18n is designed to protect against HTML/script injection by escaping interpolated parameters. However, this setting fails to prevent execution of certain tag-based payloads, such as <img src=x onerror=..., if the interpolated value is inserted inside an HTML context using v-html. This may lead to a DOM-based XSS vulnerability, even when using escapeParameterHtml: true, if a translation string includes minor HTML and is rendered via v-html. Details When escapeParameterHtml: true is enabled, it correctly escapes common injection points. However, it does not sanitize entire attribute contexts, which can be used as XSS vectors via: <img src=x onerror=alert(1) PoC In your Vue I18n configuration: Use this interpolated payload: const payload = '<scriptalert("xss")</script'; Render the translation using v-html (even not using v-html): <p v-html="$t('vulnerable', { payload })"</p Expected: escaped content should render as text, not execute.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x8qp-wqqm-57ph

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x8qp-wqqm-57ph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53892

Advisory: vue-i18n's escapeParameterHtml does not prevent DOM-based XSS through its tag attributes
IDs: CVE-2025-53892, GHSA-x8qp-wqqm-57ph
Record: https://patchnext.com/advisories/cve-2025-53892 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @intlify/vue-i18n-core 11.1.10, 10.0.8, 9.14.5; vue-i18n 11.1.10, 10.0.8, 9.14.5; petite-vue-i18n 11.1.10, 10.0.8; @intlify/core-base 11.1.10, 10.0.8, 9.14.5; @intlify/core 11.1.10, 10.0.8, 9.14.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @intlify/vue-i18n-core: affected >= 9.2.0, < 9.14.5; >= 10.0.0, < 10.0.8; >= 11.0.0, < 11.1.10; fixed in 9.14.5, 10.0.8, 11.1.10
- npm vue-i18n: affected >= 9.0.0, < 9.14.5; >= 10.0.0, < 10.0.8; >= 11.0.0, < 11.1.10; fixed in 9.14.5, 10.0.8, 11.1.10
- npm petite-vue-i18n: affected >= 10.0.0, < 10.0.8; >= 11.0.0, < 11.1.10; fixed in 10.0.8, 11.1.10
- npm @intlify/core-base: affected >= 9.0.0, < 9.14.5; >= 10.0.0, < 10.0.8; >= 11.0.0, < 11.1.10; fixed in 9.14.5, 10.0.8, 11.1.10
- npm @intlify/core: affected >= 9.0.0, < 9.14.5; >= 10.0.0, < 10.0.8; >= 11.0.0, < 11.1.10; fixed in 9.14.5, 10.0.8, 11.1.10

## Suggested inspection (read-only)
- `npm ls @intlify/vue-i18n-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls petite-vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @intlify/core-base --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @intlify/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @intlify/vue-i18n-core, vue-i18n, petite-vue-i18n, @intlify/core-base, @intlify/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x8qp-wqqm-57ph (OSV record GHSA-x8qp-wqqm-57ph lists affected ranges: npm vue-i18n >=9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.2.0 =10.0.0 =11.0.0 =10.0.0 <10.0.8 (fixed),…)
- Verified: https://github.com/advisories/GHSA-x8qp-wqqm-57ph (GitHub-reviewed advisory GHSA-x8qp-wqqm-57ph lists affected ranges: npm vue-i18n >=9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.2.0 =10.0.0 =11.0.0 =10.0.0 =11.0.0 <11.1.10)

Commands are suggestions: review each one before running it.

Loading voting…