Skip to content

← Actionable
Medium, CVSS 6.5amended

Directus' insufficient permission checks can enable unauthenticated users to manually trigger Flows

CVE-2025-53889GHSA-7cvf-pxgp-42fc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 11.9.0
    Fixed in
    11.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-53889: 0.46% estimated exploitation activity in the next 30 days; percentile 39.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Directus Flows with a manual trigger are not validating whether the user triggering the Flow has permissions to the items provided as payload to the Flow. Depending on what the Flow is set up to do this can lead to the Flow executing potential tasks on the attacker's behalf without authenticating. Impact Bad actors could execute the manual trigger Flows without authentication, or access rights to the said collection(s) or item(s). Users with manual trigger Flows configured are impacted as these endpoints do not currently validate if the user has read access to directusflows or to the relevant collection/items. The manual trigger Flows should have tighter security requirements as compared to webhook Flows where users are expected to perform do their own checks. Workarounds Users have to implement permission checks for read access to Flows and read access to relevant collection/items.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7cvf-pxgp-42fc

  2. Revision 1 · created ·

    Published from osv record GHSA-7cvf-pxgp-42fc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53889

Advisory: Directus' insufficient permission checks can enable unauthenticated users to manually trigger Flows
IDs: CVE-2025-53889, GHSA-7cvf-pxgp-42fc
Record: https://patchnext.com/advisories/cve-2025-53889 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.9.0; fixed in 11.9.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7cvf-pxgp-42fc (OSV record GHSA-7cvf-pxgp-42fc lists affected ranges: npm directus >=0 <11.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7cvf-pxgp-42fc (GitHub-reviewed advisory GHSA-7cvf-pxgp-42fc lists affected ranges: npm directus >=0 <11.9.0)

Commands are suggestions: review each one before running it.

Loading voting…