Skip to content

← Actionable
Medium, CVSS 5.3amended

Directus' exact version number is exposed by the OpenAPI Spec

CVE-2025-53887GHSA-rmjh-cf9q-pv7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 11.9.0
    Fixed in
    11.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-53887: 1.02% estimated exploitation activity in the next 30 days; percentile 63.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The exact Directus version number is incorrectly being used as OpenAPI Spec version this means that it is being exposed by the /server/specs/oas endpoint without authentication. Impact With the exact version information a malicious attacker can look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rmjh-cf9q-pv7q

  2. Revision 1 · created ·

    Published from osv record GHSA-rmjh-cf9q-pv7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53887

Advisory: Directus' exact version number is exposed by the OpenAPI Spec
IDs: CVE-2025-53887, GHSA-rmjh-cf9q-pv7q
Record: https://patchnext.com/advisories/cve-2025-53887 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.9.0; fixed in 11.9.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rmjh-cf9q-pv7q (OSV record GHSA-rmjh-cf9q-pv7q lists affected ranges: npm directus >=0 <11.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rmjh-cf9q-pv7q (GitHub-reviewed advisory GHSA-rmjh-cf9q-pv7q lists affected ranges: npm directus >=0 <11.9.0)

Commands are suggestions: review each one before running it.

Loading voting…