Skip to content

← Actionable
Medium, CVSS 4.2amended

Directus is vulnerable to sensitive data exposure as user data is not being redacted when logged

CVE-2025-53885GHSA-x3vm-88hf-gpxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 9.0.0, < 11.9.0
    Fixed in
    11.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-53885: 0.20% estimated exploitation activity in the next 30 days; percentile 10.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When using Directus Flows to handle CRUD events for users it is possible to log the incoming data to console using the "Log to Console" operation and a template string. Impact Malicious admins can log sensitive data from other users when they are created or updated. Workarounds Avoid logging sensitive data to the console outside the context of development.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x3vm-88hf-gpxp

  2. Revision 1 · created ·

    Published from osv record GHSA-x3vm-88hf-gpxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53885

Advisory: Directus is vulnerable to sensitive data exposure as user data is not being redacted when logged
IDs: CVE-2025-53885, GHSA-x3vm-88hf-gpxp
Record: https://patchnext.com/advisories/cve-2025-53885 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 9.0.0, < 11.9.0; fixed in 11.9.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3vm-88hf-gpxp (OSV record GHSA-x3vm-88hf-gpxp lists affected ranges: npm directus >=9.0.0 <11.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x3vm-88hf-gpxp (GitHub-reviewed advisory GHSA-x3vm-88hf-gpxp lists affected ranges: npm directus >=9.0.0 <11.9.0)

Commands are suggestions: review each one before running it.

Loading voting…