Indico vulnerability allows attackers to bulk dump user details
CVE-2025-53640GHSA-q28v-664f-q6wj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI indico
- Affected
- >= 2.2, < 3.3.7
- Fixed in
- 3.3.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q28v-664f-q6wj lists affected ranges: PyPI indico >=2.2 <3.3.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q28v-664f-q6wj lists affected ranges: PyPI indico >=2.2 <3.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2025-53640: 0.66% estimated exploitation activity in the next 30 days; percentile 51.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An endpoint used to display details of users listed in certain fields (such as ACLs) could be misused to dump basic user details (such as name, affiliation and email) in bulk. [!TIP] If your instance allows everyone to create a user account, and you wish to truly restrict access to these user details, consider restricting user search to managers. You can find details on the newly introduced indico.conf setting ALLOWPUBLICUSERSEARCH in our documentation. Patches You should to update to Indico 3.3.7 as soon as possible. See the docs for instructions on how to update. Workarounds It is possible to restrict access to the affected endpoints (e.g. in the webserver config), but doing so would break certain form fields which could no longer show the details of the users listed in those fields, so upgrading instead is highly recommended. For more information If you have any questions or comments about this advisory: - Open a thread in our forum - Email us privately at…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q28v-664f-q6wj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q28v-664f-q6wj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53640 Advisory: Indico vulnerability allows attackers to bulk dump user details IDs: CVE-2025-53640, GHSA-q28v-664f-q6wj Record: https://patchnext.com/advisories/cve-2025-53640 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: indico 3.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI indico: affected >= 2.2, < 3.3.7; fixed in 3.3.7 ## Suggested inspection (read-only) - `python -m pip show indico`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on indico. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q28v-664f-q6wj (OSV record GHSA-q28v-664f-q6wj lists affected ranges: PyPI indico >=2.2 <3.3.7 (fixed)) - Verified: https://github.com/advisories/GHSA-q28v-664f-q6wj (GitHub-reviewed advisory GHSA-q28v-664f-q6wj lists affected ranges: PyPI indico >=2.2 <3.3.7) Commands are suggestions: review each one before running it.
Loading voting…