@pdfme/common vulnerable to to XSS and Prototype Pollution through its expression evaluation
CVE-2025-53626GHSA-54xv-94qv-2gfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/common 5.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @pdfme/common
- Affected
- >= 5.2.0, < 5.4.1
- Fixed in
- 5.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-54xv-94qv-2gfg lists affected ranges: npm @pdfme/common >=5.2.0 <5.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-54xv-94qv-2gfg lists affected ranges: npm @pdfme/common >=5.2.0 <5.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-53626: 0.33% estimated exploitation activity in the next 30 days; percentile 26.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The expression evaluation feature in pdfme 5.2.0 to 5.4.0 contains critical vulnerabilities allowing sandbox escape leading to XSS and prototype pollution attacks. Details 1. Sandbox Escape Leading to XSS The expression evaluator's sandbox can be bypassed to execute arbitrary JavaScript code. Attackers can obtain the Function constructor through indirect methods: Both payloads bypass the sandbox restrictions and execute Function("alert(location)")(). 2. Prototype Pollution The expression evaluator allows access to prototype accessor methods which can be exploited with Object.assign to pollute the prototype chain: - lookupGetter - lookupSetter - defineGetter - defineSetter Impact These vulnerabilities allow attackers to: - Execute arbitrary JavaScript code in the context of the application - Steal sensitive information including cookies and tokens - Modify application behavior through prototype pollution - Potentially perform actions on behalf of users Proof of Concept Loading…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-54xv-94qv-2gfg
- Revision 1 · created ·
Published from osv record GHSA-54xv-94qv-2gfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53626 Advisory: @pdfme/common vulnerable to to XSS and Prototype Pollution through its expression evaluation IDs: CVE-2025-53626, GHSA-54xv-94qv-2gfg Record: https://patchnext.com/advisories/cve-2025-53626 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @pdfme/common 5.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @pdfme/common: affected >= 5.2.0, < 5.4.1; fixed in 5.4.1 ## Suggested inspection (read-only) - `npm ls @pdfme/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @pdfme/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-54xv-94qv-2gfg (OSV record GHSA-54xv-94qv-2gfg lists affected ranges: npm @pdfme/common >=5.2.0 <5.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-54xv-94qv-2gfg (GitHub-reviewed advisory GHSA-54xv-94qv-2gfg lists affected ranges: npm @pdfme/common >=5.2.0 <5.4.1) Commands are suggestions: review each one before running it.
Loading voting…