Skip to content

← Actionable
Critical, CVSS 10.0amended

docusaurus-plugin-content-gists vulnerability exposes GitHub Personal Access Token

CVE-2025-53624GHSA-qf34-qpr4-5pph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (docusaurus-plugin-content-gists 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-53624: 2.05% estimated exploitation activity in the next 30 days; percentile 81.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GitHub Personal Access Token Exposure in docusaurus-plugin-content-gists Summary docusaurus-plugin-content-gists versions prior to 4.0.0 are vulnerable to exposing GitHub Personal Access Tokens in production build artifacts when passed through plugin configuration options. The token, intended for build-time API access only, is inadvertently included in client-side JavaScript bundles, making it accessible to anyone who can view the website's source code. Affected Versions - All versions < 4.0.0 Patched Versions - Version 4.0.0 and later Impact When using the affected versions with the recommended configuration pattern: The GitHub Personal Access Token is included in the webpack bundle and exposed in production builds at: - /build/assets/js/main.[hash].js This allows malicious actors to: - Extract the GitHub Personal Access Token from the website's JavaScript files - Use the stolen token to access the token owner's GitHub account with the granted permissions - Potentially access…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qf34-qpr4-5pph

  2. Revision 1 · created ·

    Published from osv record GHSA-qf34-qpr4-5pph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53624

Advisory: docusaurus-plugin-content-gists vulnerability exposes GitHub Personal Access Token
IDs: CVE-2025-53624, GHSA-qf34-qpr4-5pph
Record: https://patchnext.com/advisories/cve-2025-53624 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: docusaurus-plugin-content-gists 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm docusaurus-plugin-content-gists: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls docusaurus-plugin-content-gists --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on docusaurus-plugin-content-gists.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qf34-qpr4-5pph (OSV record GHSA-qf34-qpr4-5pph lists affected ranges: npm docusaurus-plugin-content-gists >=0 <4.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qf34-qpr4-5pph (GitHub-reviewed advisory GHSA-qf34-qpr4-5pph lists affected ranges: npm docusaurus-plugin-content-gists >=0 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…