DSpace is vulnerable to Path Traversal attacks when importing packages using Simple Archive Format
CVE-2025-53622GHSA-vhvx-8xgc-99wf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 9.1, 8.2, 7.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-api
- Affected
- < 7.6.4>= 8.0, < 8.2>= 9.0, < 9.1
- Fixed in
- 8.2, 7.6.4, 9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhvx-8xgc-99wf lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0 =9.0 <9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:L
- EPSS
- CVE-2025-53622: 0.48% estimated exploitation activity in the next 30 days; percentile 41.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A path traversal vulnerability is possible during the import of an archive (in Simple Archive Format), either from command-line (./dspace import command) or from the "Batch Import (Zip)" user interface feature. This vulnerability likely impacts all versions of DSpace 1.x <= 7.6.3, 8.0 <= 8.1, and 9.0. An attacker may craft a malicious Simple Archive Format (SAF) package where the contents file references any system files (using relative traversal sequences) which are readable by the Tomcat user. If such a package is imported, this will result in sensitive content disclose, including retrieving arbitrary files or configurations from the server where DSpace is running. The Simple Archive Format (SAF) importer / Batch Import (Zip) is only usable by site administrators (from user interface / REST API) or system administrators (from command-line). Therefore, to exploit this vulnerability, the malicious payload would have to be provided by an attacker and trusted by an administrator…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vhvx-8xgc-99wf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53622 Advisory: DSpace is vulnerable to Path Traversal attacks when importing packages using Simple Archive Format IDs: CVE-2025-53622, GHSA-vhvx-8xgc-99wf Record: https://patchnext.com/advisories/cve-2025-53622 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 9.1, 8.2, 7.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-api: affected < 7.6.4; >= 8.0, < 8.2; >= 9.0, < 9.1; fixed in 8.2, 7.6.4, 9.1 ## Suggested inspection (read-only) - Maven org.dspace:dspace-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vhvx-8xgc-99wf (GitHub-reviewed advisory GHSA-vhvx-8xgc-99wf lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0 =9.0 <9.1) Commands are suggestions: review each one before running it.
Loading voting…