Skip to content

← Actionable
Medium, CVSS 6.9

DSpace is vulnerable to XML External Entity injection during archive imports

CVE-2025-53621GHSA-jjwr-5cfh-7xwh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 9.1, 8.2, 7.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:L
EPSS
  • CVE-2025-53621: 0.44% estimated exploitation activity in the next 30 days; percentile 37.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Two related XXE injection possibilities have been discovered, impacting all versions of DSpace prior to 7.6.4, 8.2 and 9.1. 1. External entities are not disabled when parsing XML files during import of an archive (in Simple Archive Format), either from command-line (./dspace import command) or from the "Batch Import (Zip)" user interface feature. (Likely impacts all versions of DSpace 1.x <= 7.6.3, 8.0 <= 8.1, and 9.0) 2. External entities are also not explicitly disabled when parsing XML responses from some upstream services (ArXiv, Crossref, OpenAIRE, Creative Commons) used in import from external sources via the user interface or REST API. (Impacts all versions of DSpace 7.0 <= 7.6.3, 8.0 <= 8.1 and 9.0) An XXE injection in these files may result in a connection being made to an attacker's site or a local path readable by the Tomcat user, with content potentially being injected into a metadata field. In the latter case, this may result in sensitive content disclosure,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jjwr-5cfh-7xwh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53621

Advisory: DSpace is vulnerable to XML External Entity injection during archive imports
IDs: CVE-2025-53621, GHSA-jjwr-5cfh-7xwh
Record: https://patchnext.com/advisories/cve-2025-53621 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 9.1, 8.2, 7.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.dspace:dspace-api: affected < 7.6.4; >= 8.0, < 8.2; >= 9.0, < 9.1; fixed in 8.2, 7.6.4, 9.1

## Suggested inspection (read-only)
- Maven org.dspace:dspace-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.dspace:dspace-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jjwr-5cfh-7xwh (GitHub-reviewed advisory GHSA-jjwr-5cfh-7xwh lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0 =9.0 <9.1)

Commands are suggestions: review each one before running it.

Loading voting…