Rust Web Push is vulnerable to a DoS attack via a large integer in a Content-Length header
CVE-2025-53604GHSA-287x-9rff-qvcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-push 0.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io web-push
- Affected
- <= 0.10.2
- Fixed in
- 0.10.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-287x-9rff-qvcg lists affected ranges: crates.io web-push >=0 <=0.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:L
- EPSS
- CVE-2025-53604: 0.41% estimated exploitation activity in the next 30 days; percentile 35.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The web-push crate before 0.10.4 for Rust allows a denial of service (memory consumption) in the built-in clients via a large integer in a Content-Length header. The patch was initially made available in version 0.10.3, but version 0.10.3 has since been yanked.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-287x-9rff-qvcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53604 Advisory: Rust Web Push is vulnerable to a DoS attack via a large integer in a Content-Length header IDs: CVE-2025-53604, GHSA-287x-9rff-qvcg Record: https://patchnext.com/advisories/cve-2025-53604 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-push 0.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io web-push: affected <= 0.10.2; fixed in 0.10.4 ## Suggested inspection (read-only) - crates.io web-push: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-push. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-287x-9rff-qvcg (GitHub-reviewed advisory GHSA-287x-9rff-qvcg lists affected ranges: crates.io web-push >=0 <=0.10.2) Commands are suggestions: review each one before running it.
Loading voting…