Skip to content

← Actionable
Medium, CVSS 6.9amended

fastapi-guard is vulnerable to ReDoS through inefficient regex

CVE-2025-53539GHSA-j47q-rc62-w448

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-guard 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-53539: 0.48% estimated exploitation activity in the next 30 days; percentile 41.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary fastapi-guard detects penetration attempts by using regex patterns to scan incoming requests. However, some of the regex patterns used in detection are extremely inefficient and can cause polynomial complexity backtracks when handling specially crafted inputs. It is not as severe as exponential complexity ReDoS, but still downgrades performance and allows DoS exploits. An attacker can trigger high cpu usage and make a service unresponsive for hours by sending a single request in size of KBs. PoC e.g. https://github.com/rennf93/fastapi-guard/blob/1e6c2873bfc7866adcbe5fc4da72f2d79ea552e7/guard/handlers/suspatternshandler.py#L31C79-L32C7 Single-threaded uvicorn workers can not handle any other concurrent requests during the elapsed time. Impact Penetration detection is enabled by default. Services that use fastapi-guard middleware without explicitly setting enablepenetrationdetection=False are vulnerable to DoS.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j47q-rc62-w448

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j47q-rc62-w448

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53539

Advisory: fastapi-guard is vulnerable to ReDoS through inefficient regex
IDs: CVE-2025-53539, GHSA-j47q-rc62-w448
Record: https://patchnext.com/advisories/cve-2025-53539 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastapi-guard 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastapi-guard: affected <= 3.0.0; fixed in 3.0.1

## Suggested inspection (read-only)
- `python -m pip show fastapi-guard`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastapi-guard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j47q-rc62-w448 (OSV record GHSA-j47q-rc62-w448 lists affected ranges: PyPI fastapi-guard >=0 <3.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j47q-rc62-w448 (GitHub-reviewed advisory GHSA-j47q-rc62-w448 lists affected ranges: PyPI fastapi-guard >=0 <=3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…