Better Auth Open Redirect Vulnerability in originCheck Middleware Affects Multiple Routes
CVE-2025-53535GHSA-36rg-gfq2-3h56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- <= 1.2.9
- Fixed in
- 1.2.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-36rg-gfq2-3h56 lists affected ranges: npm better-auth >=0 <1.2.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-36rg-gfq2-3h56 lists affected ranges: npm better-auth >=0 <=1.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2025-53535: 0.38% estimated exploitation activity in the next 30 days; percentile 31.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An open redirect has been found in the originCheck middleware function, which affects the following routes: /verify-email, /reset-password/:token, /delete-user/callback, /magic-link/verify, /oauth-proxy-callback. Details In the matchesPattern function, url.startsWith( can be deceived with a url that starts with one of the trustedOrigins. Open Redirect PoCs /reset-password/:token <img width="481" alt="image" src="https://github.com/user-attachments/assets/46e7871a-1dad-4375-af94-0446e29aaab6" / <br/ <img width="518" alt="image 1" src="https://github.com/user-attachments/assets/83abfb53-6fc9-4d1f-918d-9b4ce093c808" / /verify-email <img width="549" alt="image" src="https://github.com/user-attachments/assets/7dd424b7-42a4-4616-aa73-fcc2e3eeb309" / <br/ <img width="436" alt="image" src="https://github.com/user-attachments/assets/54f11636-0a3e-4e83-9a09-57c5e8ba98cd" / /delete-user/callback <img width="545" alt="image"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-36rg-gfq2-3h56
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-36rg-gfq2-3h56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53535 Advisory: Better Auth Open Redirect Vulnerability in originCheck Middleware Affects Multiple Routes IDs: CVE-2025-53535, GHSA-36rg-gfq2-3h56 Record: https://patchnext.com/advisories/cve-2025-53535 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected <= 1.2.9; fixed in 1.2.10 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-36rg-gfq2-3h56 (OSV record GHSA-36rg-gfq2-3h56 lists affected ranges: npm better-auth >=0 <1.2.10 (fixed)) - Verified: https://github.com/advisories/GHSA-36rg-gfq2-3h56 (GitHub-reviewed advisory GHSA-36rg-gfq2-3h56 lists affected ranges: npm better-auth >=0 <=1.2.9) Commands are suggestions: review each one before running it.
Loading voting…