Skip to content

← Actionable
High, CVSS 7.5

Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams

CVE-2025-53506GHSA-25xr-qj8w-c4vf

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-25xr-qj8w-c4vf lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =8.5.0 =9.0.0.M1 =10.1.0-M1 =11.0.0-M1 <11.0.9

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-53506: 2.13% estimated exploitation activity in the next 30 days; percentile 81.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-25xr-qj8w-c4vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53506

Advisory: Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams
IDs: CVE-2025-53506, GHSA-25xr-qj8w-c4vf
Record: https://patchnext.com/advisories/cve-2025-53506 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.9, 10.1.43, 9.0.107; org.apache.tomcat.embed:tomcat-embed-core 11.0.9, 10.1.43, 9.0.107. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.9; >= 10.1.0-M1, < 10.1.43; >= 9.0.0.M1, < 9.0.107; >= 8.5.0, <= 8.5.100; fixed in 11.0.9, 9.0.107, 10.1.43
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.5.0, <= 8.5.100; >= 9.0.0.M1, < 9.0.107; >= 10.1.0-M1, < 10.1.43; >= 11.0.0-M1, < 11.0.9; fixed in 11.0.9, 9.0.107, 10.1.43

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-25xr-qj8w-c4vf (GitHub-reviewed advisory GHSA-25xr-qj8w-c4vf lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =8.5.0 =9.0.0.M1 =10.1.0-M1 =11.0.0-M1 <11.0.9)

Commands are suggestions: review each one before running it.

Loading voting…