Skip to content

← Actionable
High, CVSS 8.6

Citizen vulnerable to Stored XSS through short descriptions

CVE-2025-53370GHSA-prmv-7r8c-794g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (starcitizentools/citizen-skin 3.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2025-53370: 0.38% estimated exploitation activity in the next 30 days; percentile 31.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Short descriptions set via the ShortDescription extension are inserted as raw HTML by the Citizen skin, allowing any user to insert arbitrary HTML into the DOM by editing a page. Details The shortdesc property, which contains unsanitized user input, is retrieved from the OutputPage and returned as the tagline: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/0d8a44011e02a081618359a1e90f462478e807aa/includes/Components/CitizenComponentPageHeading.php#L249-L251 The tagline is then provided to the template data: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/0d8a44011e02a081618359a1e90f462478e807aa/includes/Components/CitizenComponentPageHeading.php#L270-L275 The template then inserts the tagline into raw HTML without doing any escaping: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/0d8a44011e02a081618359a1e90f462478e807aa/templates/PageHeading.mustache#L12 PoC 1. Enable Citizen and ShortDescription 2. Add {{SHORTDESC:<img…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-prmv-7r8c-794g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53370

Advisory: Citizen vulnerable to Stored XSS through short descriptions
IDs: CVE-2025-53370, GHSA-prmv-7r8c-794g
Record: https://patchnext.com/advisories/cve-2025-53370 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: starcitizentools/citizen-skin 3.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist starcitizentools/citizen-skin: affected >= 1.9.4, < 3.4.0; fixed in 3.4.0

## Suggested inspection (read-only)
- Packagist starcitizentools/citizen-skin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on starcitizentools/citizen-skin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-prmv-7r8c-794g (GitHub-reviewed advisory GHSA-prmv-7r8c-794g lists affected ranges: Packagist starcitizentools/citizen-skin >=1.9.4 <3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…