Skip to content

← Actionable
High, CVSS 8.7amended

MCP Python SDK vulnerability in the FastMCP Server causes validation error, leading to DoS

CVE-2025-53366GHSA-3qhf-m339-9g5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mcp

    Affected
    < 1.9.4
    Fixed in
    1.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-53366: 9.75% estimated exploitation activity in the next 30 days; percentile 95.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A validation error in the MCP SDK can cause an unhandled exception when processing malformed requests, resulting in service unavailability (500 errors) until manually restarted. Impact may vary depending on the deployment conditions, and presence of infrastructure-level resilience measures. Thank you to Rich Harang for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3qhf-m339-9g5v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3qhf-m339-9g5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53366

Advisory: MCP Python SDK vulnerability in the FastMCP Server causes validation error, leading to DoS
IDs: CVE-2025-53366, GHSA-3qhf-m339-9g5v
Record: https://patchnext.com/advisories/cve-2025-53366 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp: affected < 1.9.4; fixed in 1.9.4

## Suggested inspection (read-only)
- `python -m pip show mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3qhf-m339-9g5v (OSV record GHSA-3qhf-m339-9g5v lists affected ranges: PyPI mcp >=0 <1.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-3qhf-m339-9g5v (GitHub-reviewed advisory GHSA-3qhf-m339-9g5v lists affected ranges: PyPI mcp >=0 <1.9.4)

Commands are suggestions: review each one before running it.

Loading voting…