Parse Server exposes the data schema via GraphQL API
CVE-2025-53364GHSA-48q3-prgv-gm4w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 8.2.2, 7.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 8.0.0, < 8.2.2>= 5.3.0, < 7.5.3
- Fixed in
- 7.5.3, 8.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48q3-prgv-gm4w lists affected ranges: npm parse-server >=8.0.0 =5.3.0 <7.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48q3-prgv-gm4w lists affected ranges: npm parse-server >=8.0.0 =5.3.0 <7.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-53364: 0.96% estimated exploitation activity in the next 30 days; percentile 61.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Parse Server GraphQL API previously allowed public access to the GraphQL schema without requiring a session token or the master key. While schema introspection reveals only metadata and not actual data, this metadata can still expand the potential attack surface. Patches The issue has been addressed by requiring the master key for schema introspection. Additionally, a new Parse Server configuration option, graphQLPublicIntrospection, has been introduced. This option allows developers to re-enable public schema introspection if their application relies on it. However, it is strongly recommended to use this option only temporarily and to update the application to function without depending on public introspection. Workarounds None available. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-48q3-prgv-gm4w - Fix for Parse Server 7: https://github.com/parse-community/parse-server/pull/9820 - Fix for Parse Server 8:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-48q3-prgv-gm4w
- Revision 1 · created ·
Published from osv record GHSA-48q3-prgv-gm4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53364 Advisory: Parse Server exposes the data schema via GraphQL API IDs: CVE-2025-53364, GHSA-48q3-prgv-gm4w Record: https://patchnext.com/advisories/cve-2025-53364 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 8.2.2, 7.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 8.0.0, < 8.2.2; >= 5.3.0, < 7.5.3; fixed in 7.5.3, 8.2.2 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48q3-prgv-gm4w (OSV record GHSA-48q3-prgv-gm4w lists affected ranges: npm parse-server >=8.0.0 =5.3.0 <7.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-48q3-prgv-gm4w (GitHub-reviewed advisory GHSA-48q3-prgv-gm4w lists affected ranges: npm parse-server >=8.0.0 =5.3.0 <7.5.3) Commands are suggestions: review each one before running it.
Loading voting…