ethereum does not check transaction malleability for EIP-2930, EIP-1559 and EIP-7702 transactions
CVE-2025-53359GHSA-3w94-vq2x-v5wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethereum 0.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ethereum
- Affected
- < 0.18.0
- Fixed in
- 0.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3w94-vq2x-v5wr lists affected ranges: crates.io ethereum >=0 <0.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-53359: 0.41% estimated exploitation activity in the next 30 days; percentile 35.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Prior to ethereum crate v0.18.0, signature malleability (according to EIP-2) was only checked for "legacy" transactions, but not for EIP-2930, EIP-1559 and EIP-7702 transactions. This is a specification deviation and therefore a high severity advisory if the ethereum crate is used for Ethereum mainnet. Note that signature malleability itself is not a security issue, and therefore if the ethereum crate is used on a single-implementation blockchain, it's a low/informational severity advisory. Patches The issue is fixed in ethereum v0.18.0 Workarounds You can also manually check transaction malleability outside of the crate. But it's recommended to simply upgrade the version. References See PR: https://github.com/rust-ethereum/ethereum/pull/67
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3w94-vq2x-v5wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53359 Advisory: ethereum does not check transaction malleability for EIP-2930, EIP-1559 and EIP-7702 transactions IDs: CVE-2025-53359, GHSA-3w94-vq2x-v5wr Record: https://patchnext.com/advisories/cve-2025-53359 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethereum 0.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ethereum: affected < 0.18.0; fixed in 0.18.0 ## Suggested inspection (read-only) - crates.io ethereum: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethereum. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3w94-vq2x-v5wr (GitHub-reviewed advisory GHSA-3w94-vq2x-v5wr lists affected ranges: crates.io ethereum >=0 <0.18.0) Commands are suggestions: review each one before running it.
Loading voting…