Graylog vulnerable to privilege escalation through API tokens
CVE-2025-53106GHSA-3m86-c9x3-vwm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.graylog2:graylog2-server 6.3.0-rc.2, 6.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.graylog2:graylog2-server
- Affected
- >= 6.2.0, < 6.2.4>= 6.3.0-alpha.1, < 6.3.0-rc.2
- Fixed in
- 6.2.4, 6.3.0-rc.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3m86-c9x3-vwm9 lists affected ranges: Maven org.graylog2:graylog2-server >=6.2.0 =6.3.0-alpha.1 <6.3.0-rc.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-53106: 0.61% estimated exploitation activity in the next 30 days; percentile 49.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Graylog users can gain elevated privileges by creating and using API tokens for the local Administrator or any other user for whom the malicious user knows the ID. For the attack to succeed, the attacker needs a user account in Graylog. They can then proceed to issue hand-crafted requests to the Graylog REST API and exploit a weak permission check for token creation. Workarounds In Graylog version 6.2.0 and above, regular users can be restricted from creating API tokens. The respective configuration can be found in System Configuration Users "Allow users to create personal access tokens". This option should be Disabled, so that only administrators are allowed to create tokens. Recommended Actions After upgrading Graylog from a vulnerable version to a patched version, administrators are advised to perform the following steps to ensure the integrity of their system: Review API tokens An overview of all existing API tokens is available at System Users and Teams Token Management.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3m86-c9x3-vwm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53106 Advisory: Graylog vulnerable to privilege escalation through API tokens IDs: CVE-2025-53106, GHSA-3m86-c9x3-vwm9 Record: https://patchnext.com/advisories/cve-2025-53106 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.graylog2:graylog2-server 6.3.0-rc.2, 6.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.graylog2:graylog2-server: affected >= 6.2.0, < 6.2.4; >= 6.3.0-alpha.1, < 6.3.0-rc.2; fixed in 6.2.4, 6.3.0-rc.2 ## Suggested inspection (read-only) - Maven org.graylog2:graylog2-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.graylog2:graylog2-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3m86-c9x3-vwm9 (GitHub-reviewed advisory GHSA-3m86-c9x3-vwm9 lists affected ranges: Maven org.graylog2:graylog2-server >=6.2.0 =6.3.0-alpha.1 <6.3.0-rc.2) Commands are suggestions: review each one before running it.
Loading voting…