TabberNeue vulnerable to Stored XSS through wikitext
CVE-2025-53093GHSA-jfj7-249r-7j2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (starcitizentools/tabber-neue 3.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist starcitizentools/tabber-neue
- Affected
- >= 3.0.0, < 3.1.1
- Fixed in
- 3.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfj7-249r-7j2m lists affected ranges: Packagist starcitizentools/tabber-neue >=3.0.0 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2025-53093: 0.42% estimated exploitation activity in the next 30 days; percentile 36.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Arbitrary HTML can be inserted into the DOM by inserting a payload into any allowed attribute of the <tabber tag. Details The args provided within the wikitext as attributes to the <tabber tag are passed to the TabberComponentTabs class: https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/blob/3a23b703ce36cfc4128e7921841f68230be4059a/includes/Tabber.php#L76 In TabberComponentTabs, the attributes are validated before being supplied to the Tabs template. https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/blob/3a23b703ce36cfc4128e7921841f68230be4059a/includes/Components/TabberComponentTabs.php#L15-L31 However, the validation is insufficient. What Sanitizer::validateTagAttributes does is call validateAttributes, which However, the attribute values are expected to be escaped when inserted into HTML. The attribute values are then inserted into HTML without being escaped:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jfj7-249r-7j2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-53093 Advisory: TabberNeue vulnerable to Stored XSS through wikitext IDs: CVE-2025-53093, GHSA-jfj7-249r-7j2m Record: https://patchnext.com/advisories/cve-2025-53093 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: starcitizentools/tabber-neue 3.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist starcitizentools/tabber-neue: affected >= 3.0.0, < 3.1.1; fixed in 3.1.1 ## Suggested inspection (read-only) - Packagist starcitizentools/tabber-neue: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on starcitizentools/tabber-neue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jfj7-249r-7j2m (GitHub-reviewed advisory GHSA-jfj7-249r-7j2m lists affected ranges: Packagist starcitizentools/tabber-neue >=3.0.0 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…