Skip to content

← Actionable
High, CVSS 7.5amended

Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

CVE-2025-53092GHSA-9329-mxxw-qwf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/core 5.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-53092: 0.29% estimated exploitation activity in the next 30 days; percentile 21.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A CORS misconfiguration vulnerability exists in default installations of Strapi where attacker-controlled origins are improperly reflected in API responses. Technical Details By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. Example: Origin: http://localhost:8888 Access-Control-Allow-Origin: http://localhost:8888 Access-Control-Allow-Credentials: true This allows an attacker-controlled site (on a different port, like 8888) to send credentialed requests to the Strapi backend on 1337. Suggested Fix 1. Explicitly whitelist trusted origins 2. Avoid reflecting dynamic origins

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9329-mxxw-qwf8

  2. Revision 1 · created ·

    Published from osv record GHSA-9329-mxxw-qwf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53092

Advisory: Strapi core vulnerable to sensitive data exposure via CORS misconfiguration
IDs: CVE-2025-53092, GHSA-9329-mxxw-qwf8
Record: https://patchnext.com/advisories/cve-2025-53092 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/core 5.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/core: affected < 5.20.0; fixed in 5.20.0

## Suggested inspection (read-only)
- `npm ls @strapi/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9329-mxxw-qwf8 (OSV record GHSA-9329-mxxw-qwf8 lists affected ranges: npm @strapi/core >=0 <5.20.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9329-mxxw-qwf8 (GitHub-reviewed advisory GHSA-9329-mxxw-qwf8 lists affected ranges: npm @strapi/core >=0 <5.20.0)

Commands are suggestions: review each one before running it.

Loading voting…