Skip to content

← Actionable
High, CVSS 8.2

Janssen Config API returns results without scope verification

CVE-2025-53003GHSA-373j-mhpf-84wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jans:jans-config-api-server 1.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-53003: 0.41% estimated exploitation activity in the next 30 days; percentile 35.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? The configAPI is an internal service and hence should never be exposed to the internet. With that said, this is a serious vulnerability that has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This affects all users of Janssen <1.8.0 and Gluu Flex <5.8.0 Patches Has the problem been patched? What versions should users upgrade to? All users are advised to upgrade immediately to 1.8.0 for Janssen users and 5.8.0 For Flex users. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The user can potentially fork and build the config api and patch it in their system following the commit here https://github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1 References Are there any links users can visit to find out more? https://github.com/JanssenProject/jans/issues/11575…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-373j-mhpf-84wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-53003

Advisory: Janssen Config API returns results without scope verification
IDs: CVE-2025-53003, GHSA-373j-mhpf-84wg
Record: https://patchnext.com/advisories/cve-2025-53003 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.jans:jans-config-api-server 1.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.jans:jans-config-api-server: affected < 1.8.0; fixed in 1.8.0

## Suggested inspection (read-only)
- Maven io.jans:jans-config-api-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.jans:jans-config-api-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-373j-mhpf-84wg (GitHub-reviewed advisory GHSA-373j-mhpf-84wg lists affected ranges: Maven io.jans:jans-config-api-server >=0 <1.8.0)

Commands are suggestions: review each one before running it.

Loading voting…