spytrap-adb Omission of Security-relevant Information
CVE-2025-52926GHSA-5p2p-6g2c-hf7m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spytrap-adb 0.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io spytrap-adb
- Affected
- < 0.3.5
- Fixed in
- 0.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p2p-6g2c-hf7m lists affected ranges: crates.io spytrap-adb >=0 <0.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N
- EPSS
- CVE-2025-52926: 0.16% estimated exploitation activity in the next 30 days; percentile 5.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In scan.rs in spytrap-adb before 0.3.5, matches for known stalkerware are not rendered in the interactive user interface.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5p2p-6g2c-hf7m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52926 Advisory: spytrap-adb Omission of Security-relevant Information IDs: CVE-2025-52926, GHSA-5p2p-6g2c-hf7m Record: https://patchnext.com/advisories/cve-2025-52926 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spytrap-adb 0.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io spytrap-adb: affected < 0.3.5; fixed in 0.3.5 ## Suggested inspection (read-only) - crates.io spytrap-adb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spytrap-adb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5p2p-6g2c-hf7m (GitHub-reviewed advisory GHSA-5p2p-6g2c-hf7m lists affected ranges: crates.io spytrap-adb >=0 <0.3.5) Commands are suggestions: review each one before running it.
Loading voting…