Skip to content

← Actionable
High, CVSS 8.8amended

Claude Code Improper Authorization via websocket connections from arbitrary origins

CVE-2025-52882GHSA-9f65-56v6-gxw7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 1.0.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2025-52882: 0.36% estimated exploitation activity in the next 30 days; percentile 29.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Claude Code extensions in VSCode and forks (e.g., Cursor, Windsurf, and VSCodium) and JetBrains IDEs (e.g., IntelliJ, Pycharm, and Android Studio) are vulnerable to unauthorized websocket connections from an attacker when visiting attacker-controlled webpages. Claude Code for VSCode IDE extensions versions 0.2.116 through 1.0.23 are vulnerable. For Jetbrains IDE plugins, Claude Code [beta] versions 0.1.1 through 0.1.8 are vulnerable. In VSCode (and forks), exploitation would allow an attacker to read arbitrary files, see the list of files open in the IDE, get selection and diagnostics events from the IDE, or execute code in limited situations where a user has an open Jupyter Notebook and accepts a malicious prompt. In JetBrains IDEs, an attacker could get selection events, a list of open files, and a list of syntax errors. Remediation We released a patch for this issue on June 13th, 2025. Although Claude Code auto-updates when you launch it and auto-updates the extensions, you should…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9f65-56v6-gxw7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9f65-56v6-gxw7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52882

Advisory: Claude Code Improper Authorization via websocket connections from arbitrary origins
IDs: CVE-2025-52882, GHSA-9f65-56v6-gxw7
Record: https://patchnext.com/advisories/cve-2025-52882 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 1.0.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @anthropic-ai/claude-code: affected >= 0.2.116, < 1.0.24; fixed in 1.0.24

## Suggested inspection (read-only)
- `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @anthropic-ai/claude-code.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9f65-56v6-gxw7 (OSV record GHSA-9f65-56v6-gxw7 lists affected ranges: npm @anthropic-ai/claude-code >=0.2.116 <1.0.24 (fixed))
- Verified: https://github.com/advisories/GHSA-9f65-56v6-gxw7 (GitHub-reviewed advisory GHSA-9f65-56v6-gxw7 lists affected ranges: npm @anthropic-ai/claude-code >=0.2.116 <1.0.24)

Commands are suggestions: review each one before running it.

Loading voting…