Issue with Amazon Redshift Python Connector and the BrowserAzureOAuth2CredentialsProvider plugin
CVE-2025-5279GHSA-r244-wg5g-6w2r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redshift-connector 2.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI redshift-connector
- Affected
- >= 2.0.872, <= 2.1.6
- Fixed in
- 2.1.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r244-wg5g-6w2r lists affected ranges: PyPI redshift-connector >=2.0.872 <2.1.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r244-wg5g-6w2r lists affected ranges: PyPI redshift-connector >=2.0.872 <=2.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2025-5279: 0.31% estimated exploitation activity in the next 30 days; percentile 23.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Amazon Redshift Python Connector is a pure Python connector to Redshift (i.e., driver) that implements the Python Database API Specification 2.0. When the Amazon Redshift Python Connector is configured with the BrowserAzureOAuth2CredentialsProvider plugin, the driver skips the SSL certificate validation step for the Identity Provider. Impact An insecure connection could allow an actor to intercept the token exchange process and retrieve an access token. Impacted versions: =2.0.872;<=2.1.6 Patches Upgrade Amazon Redshift Python Connector to version 2.1.7 and ensure any forked or derivative code is patched to incorporate the new fixes. Workarounds None References If you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page [1] or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue. [1] Vulnerability reporting page:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r244-wg5g-6w2r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r244-wg5g-6w2r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-5279 Advisory: Issue with Amazon Redshift Python Connector and the BrowserAzureOAuth2CredentialsProvider plugin IDs: CVE-2025-5279, GHSA-r244-wg5g-6w2r Record: https://patchnext.com/advisories/cve-2025-5279 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redshift-connector 2.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI redshift-connector: affected >= 2.0.872, <= 2.1.6; fixed in 2.1.7 ## Suggested inspection (read-only) - `python -m pip show redshift-connector`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redshift-connector. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r244-wg5g-6w2r (OSV record GHSA-r244-wg5g-6w2r lists affected ranges: PyPI redshift-connector >=2.0.872 <2.1.7 (fixed)) - Verified: https://github.com/advisories/GHSA-r244-wg5g-6w2r (GitHub-reviewed advisory GHSA-r244-wg5g-6w2r lists affected ranges: PyPI redshift-connector >=2.0.872 <=2.1.6) Commands are suggestions: review each one before running it.
Loading voting…