Skip to content

← Actionable
Medium, CVSS 6.0amended

iOS Simulator MCP Command Injection allowed via exec API

CVE-2025-52573GHSA-6f6r-m9pv-67jw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ios-simulator-mcp 1.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2025-52573: 0.66% estimated exploitation activity in the next 30 days; percentile 51.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Command Injection in MCP Server The MCP Server at https://github.com/joshuayoes/ios-simulator-mcp/ is written in a way that is vulnerable to command injection vulnerability attacks as part of some of its MCP Server tool definition and implementation. Vulnerable tool The MCP Server exposes the tool uitap which relies on Node.js child process API exec which is an unsafe and vulnerable API if concatenated with untrusted user input. LLM exposed user input for duration, udid, and x and y args can be replaced with shell meta-characters like ; or && or others to change the behavior from running the expected command idb to another command. Vulnerable line of code: https://github.com/joshuayoes/ios-simulator-mcp/blob/main/src/index.ts#L166-L207 Exploitation When LLMs are tricked through prompt injection (and other techniques and attack vectors) to call the tool with input that uses special shell characters such as ; rm -rf /tmp;

and other payload variations, the full command-line text will…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6f6r-m9pv-67jw

  2. Revision 1 · created ·

    Published from osv record GHSA-6f6r-m9pv-67jw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52573

Advisory: iOS Simulator MCP Command Injection allowed via exec API
IDs: CVE-2025-52573, GHSA-6f6r-m9pv-67jw
Record: https://patchnext.com/advisories/cve-2025-52573 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ios-simulator-mcp 1.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ios-simulator-mcp: affected < 1.3.3; fixed in 1.3.3

## Suggested inspection (read-only)
- `npm ls ios-simulator-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ios-simulator-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6f6r-m9pv-67jw (OSV record GHSA-6f6r-m9pv-67jw lists affected ranges: npm ios-simulator-mcp >=0 <1.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6f6r-m9pv-67jw (GitHub-reviewed advisory GHSA-6f6r-m9pv-67jw lists affected ranges: npm ios-simulator-mcp >=0 <1.3.3)

Commands are suggestions: review each one before running it.

Loading voting…