letmein connection limiter allows an arbitrary amount of simultaneous connections
CVE-2025-52570GHSA-jpv7-p47h-f43j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (letmeinfwd 10.2.1; letmeind 10.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io letmeinfwd
- Affected
- <= 10.2.0
- Fixed in
- 10.2.1
crates.io letmeind
- Affected
- <= 10.2.0
- Fixed in
- 10.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpv7-p47h-f43j lists affected ranges: crates.io letmeind >=0 =0 <=10.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-52570: 0.38% estimated exploitation activity in the next 30 days; percentile 31.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The connection limiter is implemented incorrectly. It allows an arbitrary amount of simultaneously incoming connections (TCP, UDP and Unix socket) for the services letmeind and letmeinfwd. Therefore, the command line option num-connections is not effective and does not limit the number of simultaneously incoming connections. letmeind is the public network facing daemon (TCP/UDP). letmeinfwd is the internal firewall daemon that only listens on local Unix socket. Possible Denial Of Service by resource exhaustion. Affected versions All versions <= 10.2.0 are affected. Patches All users shall upgrade to version 10.2.1. Workarounds Untested possible workarounds: - It might be possible to limit the number of active connections to the letmeind port (default 5800) via firewall. - The resource consumption of the service might be restricted with a service manager such as systemd. Severity: If a (D)DoS is run against the service, something is going to be affected. The connection limiter…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpv7-p47h-f43j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52570 Advisory: letmein connection limiter allows an arbitrary amount of simultaneous connections IDs: CVE-2025-52570, GHSA-jpv7-p47h-f43j Record: https://patchnext.com/advisories/cve-2025-52570 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: letmeinfwd 10.2.1; letmeind 10.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io letmeinfwd: affected <= 10.2.0; fixed in 10.2.1 - crates.io letmeind: affected <= 10.2.0; fixed in 10.2.1 ## Suggested inspection (read-only) - crates.io letmeinfwd: check the installed version with your package manager. - crates.io letmeind: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on letmeinfwd, letmeind. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpv7-p47h-f43j (GitHub-reviewed advisory GHSA-jpv7-p47h-f43j lists affected ranges: crates.io letmeind >=0 =0 <=10.2.0) Commands are suggestions: review each one before running it.
Loading voting…